[tahoe-dev] Python 2.5 is required on Windows.

zooko zooko at zooko.com
Tue Sep 18 20:42:44 UTC 2007


I think I figured out why I used to think that tahoe didn't work on  
Windows with Python 2.4:

http://allmydata.org/source/

There is a binary there for pyOpenSSL for Windows for Py2.5, but not  
one for Py2.4.  I found that binary on the web somewhere back when  
Tahoe was first released to the public, and we mirror it on  
allmydata.org for continuity.

I will go googling around the web and if I find a package named  
"pyOpenSSL-0.6.win32-py2.4.exe" then I will assume it is a good build  
of what we want (instead of a Trojan Horse) and I will add it to that  
to our mirror.

See also:

trac ticket: "I don't like pyopenssl. or pycrypto" -- http:// 
allmydata.org/trac/tahoe/ticket/11

Regards,

Zooko




More information about the tahoe-dev mailing list