[tahoe-dev] Mac install can't find OpenSSL module

zooko zooko at zooko.com
Tue Aug 12 17:27:19 UTC 2008


Hi David, I thought I should follow-up to my own post to give more  
detail:

On Aug 6, 2008, at 12:16 PM, zooko wrote:

> On Aug 6, 2008, at 12:07 PM, David Evans wrote:
>
>> I installed allmydata-tahoe-1.2.0 and when I run make test I get the
>> following error:
>>
>> ImportError: No module named OpenSSL
>
> Could you try the current trunk version.

I wasn't just asking you to try a newer version arbitrarily -- what  
you encountered is a known bug in Tahoe 1.2.0, which was fixed with  
this patch:

http://allmydata.org/trac/tahoe/changeset/2803

And so if you try the current trunk version it will probably work for  
you.

Just to be sure I tried tahoe 1.2.0 myself on Mac OS X and got the  
same error you did, then tried the current trunk and it worked.

Here is the link directly to the tarball of the version that I just  
tested:

http://allmydata.org/source/tahoe/tarballs/allmydata-tahoe-1.2.0- 
r2859.tar.gz

Please let me know whether you are still interested in installing  
Tahoe, or what.

Regards,

Zooko



More information about the tahoe-dev mailing list