[tahoe-dev] [tahoe-lafs] #534: "tahoe cp" command encoding issue

tahoe-lafs trac at allmydata.org
Thu Apr 9 03:02:29 UTC 2009


#534: "tahoe cp" command encoding issue
-----------------------------------+----------------------------------------
     Reporter:  francois           |       Owner:  francois                          
         Type:  defect             |      Status:  assigned                          
     Priority:  minor              |   Milestone:  1.5.0                             
    Component:  code-frontend-cli  |     Version:  1.2.0                             
   Resolution:                     |    Keywords:  cp encoding unicode filename utf-8
Launchpad_bug:                     |  
-----------------------------------+----------------------------------------

Comment(by zooko):

 I'm trying to understand this patch better by splitting it up into smaller
 patches.  Here is a version of it which strips out all the
 {{{unicode_to_stdout()}}} (which I subsequently realized is not a bad
 idea).  The next step probably ought to be splitting this one into yet
 smaller patches -- such as everything to do with aliases in one, and
 everything to do with files in another, and everything to do with cmdline
 args in a third.  Not sure if these can be cleanly separated (since
 filenames and aliases can come in through the cmdline args, for example),
 but I might try and see if I understand it better by the attempt.  :-)

-- 
Ticket URL: <http://allmydata.org/trac/tahoe/ticket/534#comment:53>
tahoe-lafs <http://allmydata.org>
secure decentralized file storage grid


More information about the tahoe-dev mailing list