[tahoe-dev] buildbot status -- Ruben Fedora (was: let's release what we've got (was: plans for tahoe-1.4.0))

Zooko O'Whielacronx zooko at zooko.com
Fri Apr 24 23:56:19 UTC 2009


(following-up to my own post)

On Apr 24, 2009, at 17:19 PM, Zooko O'Whielacronx wrote:

> http://allmydata.org/buildbot/builders/Ruben%20Fedora/builds/74/ 
> steps/test/logs/stdio
...
> (I sure hope raising AttributeError on import isn't an expected  
> behavior of numpy... :-))
...
> Then, the next two times Ruben pressed the "Force Build" button it  
> got signal 11 in the backup test!
>
> http://allmydata.org/buildbot/builders/Ruben%20Fedora/builds/75/ 
> steps/test/logs/stdio

Oh, I get it.  The first problem *was* a flaw in the installation of  
numpy on that system and Ruben already fixed it and then went on to  
try the build again.   Right?

Okay, now I sort of suspect that the signal 11 has to do with the  
*other* dependency (but only for an "extra" feature) that we recently  
added but we didn't include in our dependencies metadata -- sqlite.   
Ruben, could you please do

python ./setup.py test -s allmydata.test.test_cli.Backup.test_backup

On the command-line and see if it gets signal 11?  And if it does,  
could you then try it with strace or valgrind or something to learn  
more about why it crashes?

Thanks!

Brian:

With sqlite, too, we should either add it is an "Extras" requirement  
or just as an added requirement (making the backupdb non-optional).   
What do you think?

Regards,

Zooko



More information about the tahoe-dev mailing list