[tahoe-dev] Why no error message when I have only one storage node?

Zooko Wilcox-O'Hearn zooko at zooko.com
Sun Aug 2 17:29:41 UTC 2009


On Sunday,2009-08-02, at 10:57 , <gc20090728 at metcarob.com>  
<gc20090728 at metcarob.com> wrote:

> I have set up a grid with one intorducer node and one storage node.  
> I took my browser to the 3456 port as the instructions say and I  
> was surprised when I was able to sucessfully upload a file.
>
> As I understand it tahoe will split the file into 10 parts and save  
> each part on a diffrent server. This would mean that if a server  
> crashes you still can get the file. I was expecting to have an  
> error message saying that the grid wasn't big enough to reliably  
> save the file. Instead all the parts of the file have been saved on  
> the same server. Why isn't the error message there?

Thank you for the bug report.  Your issue is somewhat relevant to  
ticket #573.  I've opened a new ticket for this issue: #778.  It is  
the only ticket currently marked as "critical" and the only ticket  
the keyword "reliability".

Regards,

Zooko

tickets mentioned in this email:
http://allmydata.org/trac/tahoe/ticket/573 # Allow client to control  
which storage servers receive shares
http://allmydata.org/trac/tahoe/ticket/614 # redefine "Healthy" to be  
7 in 3-of-10 encoding
http://allmydata.org/trac/tahoe/ticket/778 # "shares of happiness" is  
the wrong measure; "servers of happiness" is better



More information about the tahoe-dev mailing list