[tahoe-dev] No module named python....

Samps listman at unplugd.com
Thu Aug 6 00:43:02 UTC 2009


On Tue, 4 Aug 2009 10:18:17 pm Zooko Wilcox-O'Hearn wrote:
> Hello Samps Okholm.
>
> Thanks for the report.
>
> Our apt repositories are not fully operational at this time, see
> http://allmydata.org/trac/tahoe/wiki/DownloadDebianPackages for
> details.  I'm surprised that you managed to install Tahoe-LAFS at all
> with "apt-get".  That wiki page I just referenced suggests that you
> use http://allmydata.org/source/tahoe/trunk/docs/install.html instead
> of apt-get, and emphasizes that this will not in any way interfere
> with your system configuration.
>
Zooko, tahnks for taking your time to help me.

I'll try to retrace my steps.

I come from the TiddlyWiki society, where you posted a link to an 
announcement, which I followed to 
http://allmydata.org/source/tahoe/trunk/docs/about.html.

I quickly got to the link saying: install.html and it took me to 
http://allmydata.org/source/tahoe/trunk/docs/install.html where I found the 
download link 
(http://allmydata.org/source/tahoe/releases/allmydata-tahoe-1.5.0.zip) for 
the 1.5.0 release as a zipped package and downloaded that. Unzipped it to my 
home, CD-ed into it and executed 'python setup.py build' (python -V reports 
2.5.2 btw) and something happened. Not enough apparently, because it ended 
with some cryptic message, which I can not replicate today, about gcc not 
having enough parameters. Anyway, no 'tahoe' was created in the 'bin' folder 
and the "install from documentation" track stopped here.

> Hm, in fact from what you report it looks like you have Tahoe-LAFS
> installed *not* from apt but from running either "python ./setup.py
> install" or from running "easy_install allmydata-tahoe".  Do you
> remember which of those you tried? 

Yes. The 'python setup.py' way. I have never heard of 'easy_install'.

> More interestingly to me, what 
> document did you read that made you think of trying that?  Whatever
> document suggested that to you, I want to find it and change it to
> instead suggest that you follow the instructions in http://
> allmydata.org/source/tahoe/trunk/docs/install.html .

I tried the zip-package/python way before the deb/apt way.

>
> A-ha!  I think I've found it.  I just removed a paragraph from the
> DownloadDebianPackages page which mentioned that you could run
> "python ./setup.py install" (although it wasn't exactly recommending
> that you do so).  Is this the paragraph that led you to do that?
>
> http://allmydata.org/trac/tahoe/wiki/DownloadDebianPackages?
> action=diff&version=24
>
> Do you remember exactly what steps you took?  Because I don't
> understand how you got /usr/lib/python2.5/site-packages/
> allmydata_tahoe-1.5.0_r4042-py2.5.egg/ into place without also
> getting a working installation of Twisted.

From the 'installDetails Wiki page 
(http://allmydata.org/trac/tahoe/wiki/InstallDetails) I found a link to the 
Debian/Ubuntu installation from repo page 
http://allmydata.org/trac/tahoe/wiki/DownloadDebianPackages where I grabbed 
info about the repositories and used Synaptic to install 'allmydata-tahoe', 
only, it failed to retrieve one package, namely 'allmydata-tahoe.deb'. I 
installed the other stuff as I thought it might help me if I went back to 
installing using Python, then I went to http://allmydata.org/debian/ where I 
found a copy of allmydata-tahoe_1.5.0-r4042_all.deb buried deep down in 
http://allmydata.org/debian/dists/hardy/tahoe/binary-i386/. I downloaded it, 
installed it and ended up with an installation that reports: "No module named 
python..."

>
> Anyway, the short answer is: follow the instructions in
> install.html , do not follow any instructions from any other
> document, and you should be fine.
>

Here comes the funny bit....  This morning I tried again, keeping everything 
on my 'Desktop', download zip-package, unzip, open 'Terminal', 'CD 
allmydata-tahoe-1.5.0', 'python setup.py build', lots of output to terminal, 
all looking well and good and mostly about creating and copying.
Trying to get version of 'tahoe' with 'bin/tahoe --version returns a lot 
messages, last one saying: ImportError: No module named python


Sorry to be a nuisance

Samps



More information about the tahoe-dev mailing list