[tahoe-dev] [tahoe-lafs] #681: make the error message more helpful in case of no 'tahoe' alias (was: Unable to run some commands)

tahoe-lafs trac at allmydata.org
Thu Aug 6 12:33:31 UTC 2009


#681: make the error message more helpful in case of no 'tahoe' alias
-------------------------------+--------------------------------------------
 Reporter:  prmr               |           Owner:           
     Type:  defect             |          Status:  new      
 Priority:  major              |       Milestone:  undecided
Component:  code-frontend-cli  |         Version:  1.3.0    
 Keywords:  easy               |   Launchpad_bug:           
-------------------------------+--------------------------------------------
Changes (by zooko):

  * keywords:  => easy
  * owner:  somebody =>
  * component:  operational => code-frontend-cli


Comment:

 Thanks for the bug report, prmr.  I'm sorry that it fell by the wayside
 for four months -- I don't know if I ever noticed this ticket before now.
 I'm changing the title to reflect what I think is the issue here -- that
 the error message when there is no alias registered for 'tahoe' should be
 more helpful and explain that the {{{tahoe stats}}} command expects either
 a dircap or an alias on the command-line, or else for there to be a dircap
 registered under the default 'tahoe' alias in the aliases file.

 I'm also marking this ticket as "easy" -- a young hacker who wants to get
 into Tahoe-LAFS hacking should be able to fix this ticket easily enough
 even if they aren't familiar with the codebase.

-- 
Ticket URL: <http://allmydata.org/trac/tahoe/ticket/681#comment:1>
tahoe-lafs <http://allmydata.org>
secure decentralized file storage grid


More information about the tahoe-dev mailing list