[tahoe-dev] [tahoe-lafs] #782: connection lost during "tahoe backup"

tahoe-lafs trac at allmydata.org
Wed Nov 4 00:11:25 UTC 2009


#782: connection lost during "tahoe backup"
---------------------+------------------------------------------------------
 Reporter:  zooko    |           Owner:  andrej   
     Type:  defect   |          Status:  new      
 Priority:  major    |       Milestone:  undecided
Component:  unknown  |         Version:  1.5.0    
 Keywords:           |   Launchpad_bug:           
---------------------+------------------------------------------------------

Comment(by afalout):

 In response to Zooko's comments:

 "I don't see how your theory can fit with my mental model of the Tahoe-
 LAFS network code.  Maybe if you turn on some extra logging and then
 stimulate it to fail and then post the logs then I can figure it out."

 I can confirm without any uncertainty that running a P2P app with large
 number of connections kills Tahoe. I even scripted this into my backup
 scripts so all P2P traffic is stopped when running Tahoe.. Lite P2P (5
 files/500 connections or so) is OK but anything significantly over this is
 a killer.

 Now whether this means something can or even should be changed in Tahoe,
 is another matter entirely.

 I would argue that for an application that is supposed to transfer a large
 amount of data over a long period of time, ability to recover form any
 sort of network interruptions is a paramount.

 I would even go so far as not to allow Tahoe to quit for this reason at
 all, instead preferring it to retry the action indefinitely, until it
 either completes the requested operation, or user interrupts it.

-- 
Ticket URL: <http://allmydata.org/trac/tahoe/ticket/782#comment:3>
tahoe-lafs <http://allmydata.org>
secure decentralized file storage grid


More information about the tahoe-dev mailing list