[tahoe-dev] [tahoe-lafs] #843: zope recursion during build / test / install

tahoe-lafs trac at allmydata.org
Wed Nov 25 21:44:45 UTC 2009


#843: zope recursion during build / test / install
--------------------------+-------------------------------------------------
 Reporter:  nejucomo      |           Owner:  somebody 
     Type:  defect        |          Status:  new      
 Priority:  minor         |       Milestone:  undecided
Component:  packaging     |         Version:  1.5.0    
 Keywords:  zope install  |   Launchpad_bug:           
--------------------------+-------------------------------------------------
 I left my machine while running "time { python setup.py build && python
 setup.py test && python setup.py install; }".  I ran this inside of a "cd
 /media/target-disk; chroot ." on a debian system, even though /media
 /target-disk contains an ubuntu installation!

 When I returned the command output ended with:
 {{{
   File "/usr/local/src/allmydata-
 tahoe-1.5.0/zope.interface-3.5.2-py2.5-linux-x86_64.egg/zope/interface/declarations.py",
 line 1370, in _normalizeargs
     _normalizeargs(v, output)
   File "/usr/local/src/allmydata-
 tahoe-1.5.0/zope.interface-3.5.2-py2.5-linux-x86_64.egg/zope/interface/declarations.py",
 line 1370, in _normalizeargs
     _normalizeargs(v, output)
   File "/usr/local/src/allmydata-
 tahoe-1.5.0/zope.interface-3.5.2-py2.5-linux-x86_64.egg/zope/interface/declarations.py",
 line 1366, in _normalizeargs
     if InterfaceClass in cls.__mro__ or Implements in cls.__mro__:
 RuntimeError: maximum recursion depth exceeded in cmp
 }}}

 Unfortunately I cannot scroll back to see the top of the stack trace or
 more relevant logs.

 When I rerun the same command, unit tests seem to begin executing until
 they abort strangely with a different error which I will file as a
 separate ticket.

-- 
Ticket URL: <http://allmydata.org/trac/tahoe/ticket/843>
tahoe-lafs <http://allmydata.org>
secure decentralized file storage grid


More information about the tahoe-dev mailing list