[tahoe-dev] Must be overlooking something: unable to find vcvarsall.bat

David Coffey david at thecoffeycan.com
Thu Oct 22 20:51:52 UTC 2009


Vanderlinden, Chris wrote:
> Steps taken:
> 
> Steps so far I took were the following:
> 
> Installed Python 2.6.3
> Installed Pywin32-214
> Installed MinGW5.1.4(with g++)
> Grabbed the Tahoe-1.5.0.tar.gz file
> Grabbed the tahoe.deps.tar.gz file
> 
> Extracted both to c:\allmydata-tahoe-1.5.0
> 
> Ran: python setup.py build_tahoe
> (path has both C:\MinGW\bin and c:\Python26 setup)
> 
> Any ideas on what I must have overlooked?
>

Try using Python version 2.6.2
I had the same problem, and going to 2.6.2 resolved it.

I was also receiving  KeyError: '_zope_interface_coptimizations' when I 
did not use the tahoe.deps.tar.gz file

It looks like it has to do with a change in distutils in 2.6.3 that 
affected setuptools
This python bug report has more information
http://bugs.python.org/issue7064

I also found some more information in this mailing list thread.
http://mail.python.org/pipermail/distutils-sig/2009-October/013534.html


David



More information about the tahoe-dev mailing list