[tahoe-dev] [tahoe-lafs] #944: "tahoe mv" doesn't accept just a path as the second argument?

tahoe-lafs trac at allmydata.org
Tue Feb 9 02:50:54 UTC 2010


#944: "tahoe mv" doesn't accept just a path as the second argument?
--------------------------------------+-------------------------------------
 Reporter:  zooko                     |           Owner:           
     Type:  defect                    |          Status:  new      
 Priority:  major                     |       Milestone:  undecided
Component:  code-frontend-cli         |         Version:  1.6.0    
 Keywords:  tahoe-mv usability error  |   Launchpad_bug:           
--------------------------------------+-------------------------------------
Changes (by davidsarah):

  * keywords:  tahoe-mv usability => tahoe-mv usability error


Comment:

 There seem to be three issues here:
  * to match the behaviour of Unix {{{mv}}}, the destination of the first
 command should have been treated as {{{tahoe:on_ootles}}}. This only
 applies when the source is a path (rather than a direct cap), so that its
 name relative to its parent is known.
  * replace_me_with_a_childcap needs to check that {{{self.parentnode}}} is
 not None, in order to raise a more sensible error.
  * "{{{path/.}}}" or "{{{alias:.}}}" should probably be treated the same
 as "{{{path/}}}" or "{{{alias:}}}"

-- 
Ticket URL: <http://allmydata.org/trac/tahoe/ticket/944#comment:2>
tahoe-lafs <http://allmydata.org>
secure decentralized file storage grid


More information about the tahoe-dev mailing list