[tahoe-dev] multi-user tahoe node suggestions

Jody Harris imhavoc at gmail.com
Sat Jan 23 18:47:39 UTC 2010


Thanks, David-Sarah. That fixed it.

I haven't used tahoe enough to be familiar with it. I just copy/pasted
Brian's instructions.

jody
----
- Think carefully.
- Contra mundum - "Against the world" (St. Athanasius)
- Credo ut intelliga - "I believe that I may know" (St. Augustin of Hippo)


On Sat, Jan 23, 2010 at 11:34 AM, David-Sarah Hopwood <
david-sarah at jacaranda.org> wrote:

> Jody Harris wrote:
> > On Wed, Jan 13, 2010 at 12:26 PM, Brian Warner <warner at lothar.com>
> wrote:
> >
> >>  mkdir ~/.tahoe
> >>  mkdir ~/.tahoe/private
> >>  echo "http://127.0.0.1:3456/" >~/.tahoe/node.url
> >>  tahoe create-alias tahoe:
>
> This should be "tahoe create-alias tahoe"
>
> >>  echo "yay" |tahoe put - tahoe:yay.txt
> >>  tahoe get tahoe:yay.txt
> >>
> >> I tried this....
> >
> > and I got:
> >
> > $ tahoe create-alias REfiles:
>
> or "tahoe create-alias REfiles".
>
> (The traceback gives a clue, but it definitely shouldn't be an assert.
> I'll file a ticket about not using asserts for possible errors in user
> input. In this case the ":" could just be dropped.)
>
> [...]
> >     rc = tahoe_add_alias.create_alias(options)
> >   File
> >
> "/home/tahoe/allmydata-tahoe-1.5.0/src/allmydata/scripts/tahoe_add_alias.py",
> > line 34, in create_alias
> >     assert ":" not in alias
> > AssertionError
>
> --
> David-Sarah Hopwood  ⚥  http://davidsarah.livejournal.com
>
>
> _______________________________________________
> tahoe-dev mailing list
> tahoe-dev at allmydata.org
> http://allmydata.org/cgi-bin/mailman/listinfo/tahoe-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tahoe-lafs.org/pipermail/tahoe-dev/attachments/20100123/be22819a/attachment.html>


More information about the tahoe-dev mailing list