[tahoe-dev] Windows 7 install Error on 1.8

Kyle Markley kyle at arbyte.us
Tue Oct 5 04:57:37 UTC 2010


I ran into an extremely similar linking problem when I upgraded my Win7
machine from 1.7.1 to 1.8.  I was unable to link pycryptopp when building
it from source, getting errors like yours for twisted.

I ran out of time over the weekend to investigate my problem, but your
message spurred me to look right now.  It appears that my installation was
only successful because while building tahoe, the build system downloaded
the egg from here:

I actually cannot build pycryptopp from source on my system; I have to get
the .egg from somewhere else.  I vaguely recall having trouble along these
lines for twisted, too, and finding that .egg somewhere online.  That's how
I worked around the problem.  You may need to do the same.  Alas I don't
remember where I found that .egg, so I can't give you a solution.  :(

We're going to need someone who understands building this stuff on Windows
to investigate what's wrong and how to fix it.  And maybe we're going to
need some Windows 7 buildbots that have minimal software development tools
installed.  (I'm afraid I can't offer mine, as it's actually my wife's

On Mon, 4 Oct 2010 21:08:06 -0600, "Paul Grunwald" <pgrunwald at comcast.net>
> Installed MinGW and added to path as per the instructions
> Results below
> ---------------------------------------------------------------


> .tex
> t+0x41): undefined reference to `_imp__PyArg_ParseTupleAndKeywords'


Kyle Markley

More information about the tahoe-dev mailing list