[tahoe-dev] Trouble compiling on OSX

Olaf TNSB still.another.person at gmail.com
Tue Aug 2 11:36:46 UTC 2011


Hi David-Sarah & Zooko & Greg,

Thanks for the help.  Just tried to build with the latest trunk and it did
just work.  I got two errors in the test suite but they look like they were
a result of me not having darcs in my path - they were 'version' type
errors.

Zooko - do you need me to close the trac ticket?

Now I'm off to actually play with Tahoe.  :)

Olaf
On 30/07/2011 1:32 AM, "David-Sarah Hopwood" <david-sarah at jacaranda.org>
wrote:
> On 29/07/11 06:55, Olaf TNSB wrote:
>> Hi all,
>>
>> I'm a bit of a lurker and frankly more at home on Linux than the Mac
>> I'm trying to compile on (and failing).
>>
>> I'm running OSX 10.6.8 with port (macports) installed to make my
>> machine more GNU-like. I tried to follow the hugely complicated(!)
>> build instructions on
>> (http://tahoe-lafs.org/trac/tahoe-lafs/browser/trunk/docs/quickstart.rst)
>> but failed miserably. :-(
> [...]
>> AttributeError: 'MetaTypedInterface' object has no attribute '__name__'
>
> This is a known incompatibility with the latest version of one of the
> libraries we are dependent on, zope.interface 3.6.4. Please try with
> current trunk:
>
> install darcs from http://wiki.darcs.net/Binaries#mac-os-x
> darcs get --lazy http://tahoe-lafs.org/source/tahoe-lafs/trunk tahoe-lafs
> cd tahoe-lafs
> python setup.py build
>
> Then follow the rest of quickstart.rst.
>
> --
> David-Sarah Hopwood ⚥ http://davidsarah.livejournal.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tahoe-lafs.org/pipermail/tahoe-dev/attachments/20110802/dd86d54a/attachment.html>


More information about the tahoe-dev mailing list