[tahoe-dev] new foolscap version requirement

Zooko O'Whielacronx zooko at zooko.com
Thu Jan 6 14:54:46 UTC 2011

On Thu, Jan 6, 2011 at 2:11 AM, David-Sarah Hopwood
<david-sarah at jacaranda.org> wrote:
> This checks the Twisted version at the time of the build. If the user later
> installs Twisted 10.2 but still has foolscap 0.5.1, the Tahoe installation
> will break, and the user will have to rebuild it.

Good point, but how could it be otherwise? The only thing that could
avoid this would be if executing tahoe at runtime triggered automatic
installation of new versions of dependencies. I'm sure nobody here
wants that. :-)

The best thing we could do in that case, I believe, is emit a specific
error message saying that we require foolscap >= 0.6, perhaps with an
associated comment saying that the reason we require foolscap >= 0.6
is that we have Twisted >= 10.2.

Hm, oh look! That's exactly what tahoe will do:




More information about the tahoe-dev mailing list