[tahoe-dev] new foolscap version requirement
gdt at ir.bbn.com
Fri Jan 7 20:00:58 UTC 2011
quick comment (without reading the whole foolscap/twisted discussion as
thorougly as I should):
it is totally fair to expect the OS/packaging system to have versions
of foolscap and twisted that work *with each other*
it is not reasonable to demand versions of dependencies that haven't
been out for at least 3-6 months unless there is some really critical
reason why the grief is outweighed by the benefit
tahoe should be able to cope with either bleeding edge
foolscap/twisted or the ones that work together and were current 3
as to your quiz
3. You have Twisted < 10.2 and Foolscap < 0.6.0 installed. You build
Tahoe-LAFS. It is satisfied with the packages already installed
(because 1=>a). Then you manually upgrade your Twisted to == 10.2.
Then you do *not* run Tahoe-LAFS's "python setup.py build" again, but
you do run "tahoe start". What do you want it to do?
option a: emit a clear error message saying that it has Foolscap
v0.5.1 installed but it needs Foolscap v0.6.0 and stop.
option b: ?
user has broken their install because they updated twisted and not
foolscap, and new twisted requires new foolscap so option a is totally
I am firmly in the "fail if things are not ok" camp vs the "do magic to
make it work" camp.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 194 bytes
Desc: not available
More information about the tahoe-dev