[tahoe-dev] new foolscap version requirement

Zooko O'Whielacronx zooko at zooko.com
Wed Jan 12 07:52:01 UTC 2011


On Fri, Jan 7, 2011 at 2:10 PM, David-Sarah Hopwood
<david-sarah at jacaranda.org> wrote:
>> 3. You have Twisted < 10.2 and Foolscap < 0.6.0 installed.
...
> The situation shouldn't occur because 'setup.py build', by default,
> should either:
>
>  - have built a private copy of twisted < 10.2 (always used by bin/tahoe)
>   that won't be affected by upgrades of the installed version, or
>  - have built a private copy of foolscap 0.6.0 (always used by bin/tahoe).

Hrm. I can see how this could work, and could avoid the problem that
could occur if someone were to subsequently upgrade their Twisted
without upgrading their foolscap. However, I'm not sure that most
users would be okay with this--it runs contrary to the principle of
using the system-wide install of a library if possible. I'm not sure
that if I were a user I would like the Tahoe-LAFS build to do this,
and if I understand Greg Troxel's comment on this thread, it sounds
like he might have reservations too.

(Currently, the Tahoe-LAFS build scheme will automatically build a
private copy of a library but will not do so if there is already a
copy available which is of a sufficiently new version number.)

In any case, I don't want to try to implement that (plus deciding if
it is really a good idea according to users) for v1.8.2, but I *would*
be happy to apply my patch before v1.8.2, which as far as I can tell
would be strictly better than the current trunk, even if you prefer
the "aggressive private copy" scheme above even more.

So, can I get at least a +0 from David-Sarah on my patch for v1.8.2?

And also from Brian, whose begrudging complaint^W^Wuseful bug report
prompted my patch?

Regards,

Zooko



More information about the tahoe-dev mailing list