[tahoe-dev] Weird WUI Error

Michael Coppola coppola.mi at husky.neu.edu
Sun Jan 16 18:11:33 UTC 2011

On 01/16/2011 10:19 AM, David-Sarah Hopwood wrote:
> On 2011-01-16 08:22, Michael Coppola wrote:
>> Hey list,
>> I installed a new storage node the other day (which just happens to be
>> my introducer too), and I seem to have this problem where the WUI (on
>> :3456) keeps going to an "Internal Server Error" page every few hours. 
>> If I restart the process, then it's fine again, but it's back to the
>> error page when I check it a little while later.  I'm not sure what's
>> going on, because I have pretty much an identical storage installation
>> on another box that works perfectly fine.
> Thanks for the report.
> Is it possible that this disk is giving intermittent read or write errors?
> Please try copying the base directory (keeping the same permissions) to a
> different physical disk if possible, and then try to reproduce the error
> with the copy.
> _______________________________________________
> tahoe-dev mailing list
> tahoe-dev at tahoe-lafs.org
> http://tahoe-lafs.org/cgi-bin/mailman/listinfo/tahoe-dev
Maybe, I'm not sure.  I don't see any I/O errors in /var/log/messages,
but I'll keep it in mind.

After looking at it some more, I remembered/realized that the erroring
storage node was installed inside an encrypted user directory (Ubuntu's
option at installation to encrypt the user's directory in /home), so I
thought maybe something was going on there that it was being made
unavailable at times that the software was trying to access it.  Then
maybe when I logged in to fix it, it would remount the directory and
everything would be fixed just by doing that.  That's just a guess, so I
could be completely wrong.

Anyways, what I ended up doing was just creating two new base
directories outside of the encrypted user directory and reinstalling the
storage node and introducer there.  It seems to be working fine so far
(worked when I went to sleep, worked when I woke up), but I'll keep you
updated.  Thanks for the help
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tahoe-lafs.org/pipermail/tahoe-dev/attachments/20110116/e3e91e83/attachment.html>

More information about the tahoe-dev mailing list