[tahoe-dev] alternative usage

sickness sickness at tiscali.it
Wed Mar 30 06:58:57 UTC 2011

Hi all,
I'm reading the ml, chatting on the irc channel, and testing tahoe-lafs since some months now...
Zooko asked me to report my little test also on the ml so here I am :)

So instead of the already done (and succesful) toy-grid test with 10VMs, the other day I had
the idea to try to use tahoe-lafs to just get encryption on one disk, in a portable manner,
for win32 :)

So I've installed python26, pywin, built tahoe-lafs on an external usb drive, lets call it
Y:\tahoe-lafs then created an introducer Y:\tahoeintroducer and then a client/storage in Y:\tahoestorage

Then with 2 simple .bat scripts I've launched them (configured in the .cfg file to bind only to
Y:\>type *.bat


.\Python26-amd64\python.exe .\tahoe-lafs\bin\tahoe start .\tahoeintroducer

.\Python26\python.exe .\tahoe-lafs\bin\tahoe start .\tahoeintroducer

.\Python26-amd64\python.exe .\tahoe-lafs\bin\tahoe start .\tahoestorage

.\Python26\python.exe .\tahoe-lafs\bin\tahoe start .\tahoestorage

(I did .bat startup files with relative paths and with both the 32 and 64bit tahoe
aiming for some sort of portability, I've also added the python26.dll inside the python26 dir
anyway this still doesn't work as portable, but this problem is not the scope of this post,
installing python on the system makes it work just fine for now :)

Then I've started both the introducer and the storage, opened a web browser to
and tried a 700Mb file upload!
So far so good the upload was ok, but in the windows task manager I noticed that the size of the
python process of tahoe-lafs also grew to 700Mb (!!!)
Doing a check on the file from the webinterface lowered the size of the process to 90Mb, curious =)

So Zooko asked me to try adding also a dedicated client process and I've retried with also:
.\Python26-amd64\python.exe .\tahoe-lafs\bin\tahoe start .\tahoeclient

.\Python26\python.exe .\tahoe-lafs\bin\tahoe start .\tahoeclient

So I've relaunched tahoe-lafs with 3 separate processess, retried the upload, and now the memory
size of the python process is all ok (so like between 16 and 50mb max)

Then just for the sake of it, on the irc channel a discussion started about unusual way to use
tahoe-lafs, for example this configuration, or for example adding another external usb disk and
starting 2 storage nodes, configuring them to have 1:2:2, one would have a portable encrypted raid
on the cheap, all with open source tools :)

More information about the tahoe-dev mailing list