[tahoe-dev] 1.9.0 beta1 is tagged!

Marco Tedaldi marco.tedaldi at gmail.com
Fri Oct 14 17:46:06 UTC 2011


On 14.10.2011 19:22, Brian Warner wrote:
> On 10/14/11 8:04 AM, Greg Troxel wrote:
> 
>> Thanks for 1) making the unpacked dir match the version in the file and
> 
> Glad that helps.. it's part of the tarball-generation automation, so it
> should always work that way.
> 
>> I am assuming while a new foolscap release is pending, 1.9.0 will not
>> require it.
> 
> Correct. The dependency is actually going to be driven by Twisted. Tahoe
> (both current 1.8.3 and upcoming 1.9.0) is happy with both current
> Foolscap-0.6.1 and upcoming Foolscap-0.6.2 . Both current Foolscap-0.6.1
> and upcoming Foolscap-0.6.2 are happy with current Twisted-11.0.0 . But
> current Foolscap-0.6.1 is not compatible with Twisted trunk, which means
> that as soon as they make their next release, 0.6.1 won't be compatible
> with that. So Foolscap-0.6.2 will be a pre-emptive compatibility strike.
> 
So current foolscap should have the dependency on twisted listed as
<=twisted-11.0.0 or something like this. Than the package system should
take care or at least warn the user.

best

Marco



More information about the tahoe-dev mailing list